Alex Rivera | Logout

JBoss - ExportException: Port already in use: 1098

Asked 2009-06-19T19:17:03.937
10

I'm getting the following error when I try to start JBoss

10:10:43,298 INFO  [WebService] Using RMI server codebase: http://127.0.0.1:8083/
10:10:43,938 ERROR [AbstractKernelController] Error installing to Start: name=jboss:service=Naming state=Create mode=Manual requiredState=Installed
java.rmi.server.ExportException: Port already in use: 1098; nested exception is: 
    java.net.BindException: Address already in use: JVM_Bind
    at sun.rmi.transport.tcp.TCPTransport.listen(TCPTransport.java:249)
    at sun.rmi.transport.tcp.TCPTransport.exportObject(TCPTransport.java:184)
    at sun.rmi.transport.tcp.TCPEndpoint.exportObject(TCPEndpoint.java:382)
    at sun.rmi.transport.LiveRef.exportObject(LiveRef.java:116)
    at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:180)
    at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.java:293)
    at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.java:256)

However When I try to see what ports are being listened to. I don't see that port!

H:\>netstat -a -n -o

Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       824
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
  TCP    0.0.0.0:1521           0.0.0.0:0              LISTENING       2036
  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       752
  TCP    0.0.0.0:7717           0.0.0.0:0              LISTENING       2944
  TCP    0.0.0.0:8081           0.0.0.0:0              LISTENING       1564
  TCP    0.0.0.0:31038          0.0.0.0:0              LISTENING       1436
  TCP    127.0.0.1:1038         0.0.0.0:0              LISTENING       2036
  TCP    127.0.0.1:1052         0.0.0.0:0              LISTENING       2620
  TCP    127.0.0.1:5998         127.0.0.1:5999         ESTABLISHED     4036
  TCP    127.0.0.
Edit
Report

2 Answers

7

Try TCPView (TCPView v3.05). I get this "port already in use" quite a lot, and TCPView always usually catches the culprit.

answered 2009-06-21T23:23:51.320
2

The root cause is that JBOSS was not peoperly shut down. If you are using Windows, go to task manager and kill the JBOSS processes.

answered 2012-05-17T04:37:37.787

Your Answer