Following error occurs when I am trying to restore a DB in MYSQL via putty.

Command: mysql -u root -p db1<dbname.sql ;

ERROR 1 (HY000) at line 7904: Can't create/write to file './dbname/db.opt' (Errcode: 2)

What is the reason?

Edit
Report