KnowledgeHub
Questions
Tags
Users
Search
Alex Rivera
|
Logout
Edit Question
Title
Body
I have deployed a WAR file in the webapps folder in my tomcat . And when I am starting my tomcat, like below C:\apache-tomcat-6.0.35\bin>startup.bat Using CATALINA_BASE: "C:\apache-tomcat-6.0.35" Using CATALINA_HOME: "C:\apache-tomcat-6.0.35" Using CATALINA_TMPDIR: "C:\apache-tomcat-6.0.35\temp" Using JRE_HOME: "C:\Program Files (x86)\IBM\RationalSDLC\Common\Java5.0\jre" Using CLASSPATH: "C:\apache-tomcat-6.0.35\bin\bootstrap.jar" I am getting this below exception- SEVERE: Error deploying web application archive DirectoryServer.war java.lang.UnsupportedClassVersionError: (com/services/rest/Listener) bad major version at offset=6 (unable to load class com.services.rest.Listener) at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2822) at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1159) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1647) at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526) at org.apache.catalina.startup.WebAnnotationSet.loadClassAnnotation(WebAnnotationSet.java:145) at org.apache.catalina.startup.WebAnnotationSet.loadApplicationListenerAnnotations(WebAnnotationSet.java:73) at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(WebAnnotationSet.java:56) at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(ContextConfig.java:297) at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1078) at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261) at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4612) at org.apache.catalina.core.ContainerBase.addChildInternal(Cont
Tags (comma-separated)
Save Edits
Cancel