Alex Rivera | Logout

The permissions granted to user ' are insufficient for performing this operation. (rsAccessDenied)"}

Asked 2008-09-25T11:52:19.757
111

I created a report model using SSRS (2005) and published to the local server. But when I tried to run the report for the model I published using report builder I get the following error.

Report execution error:The permissions granted to user are insufficient for performing this operation. (rsAccessDenied)

Edit
Report

3 Answers

106

It's because of lack of privilege for the user you are running the report builder, just give that user or a group a privilege to run report builder. Please visit this article

Or for shortcut:

  1. Start Internet Explorer using "Run as Administrator"
  2. Open http://localhost/reports
  3. Go to the Properties tab (SSRS 2008)
  4. Security -> New Role Assignment
  5. Add DOMAIN\USERNAME or DOMAIN\USERGROUP
  6. Check Report Builder
answered 2011-06-20T06:23:16.060
20

I know it's for a long time ago but you (or any other new comers) can resolve this issue by

  1. Add the [Domain\User] to Administrator, IISUser, SQLReportingUser groups
  2. Delete Encryption Key in SSRS configuration tools
  3. ReRun the Database Change in SSRS configuration tools
  4. Open WebServiceUrl from SSRS configuration tools (http://localhost/reportserver)
  5. creating Reports Folder manually
  6. go to Properties of created folder and add these roles to security (builtin\users , builtin\Administrator, domain\user)
  7. Deploy your reports and your problem resolved
answered 2010-06-09T06:40:10.583
5

I have SQL2008 / Windows 2008 Enterprise and this is what I had to do to correct the rs.accessdenied, 404, 401 and 503 errors:

  • Added NT Users to SQL Report Server Users and IIS_USR Group
  • I changed SQL Reporting Service to Local account (it was Domain with Local Admin)
  • I deleted encryption key in Reporting Services Configuration (last tab on the list)
  • and THEN it worked.
answered 2009-08-24T23:22:56.550

Your Answer