KnowledgeHub
Questions
Tags
Users
Search
Alex Rivera
|
Logout
Edit Question
Title
Body
We're seeing an odd pattern in our QA Lab. We have two ASP.NET applications, each deployed on the same Windows 2008 SP2+ box. We have our App Pool running in a Domain Account, and set to never re-cycle. The same 1 App Pool is used by both applications. After several hours of running fine, new users surfing to a page in our application get the IIS7 Error Page, with a 500.21 error. If we do nothing but: 1) IISRESET 2) Change folder to c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files and "rd" the 2 applications. And then surf to our web applications, all is fine. Then several hours later, however, the 500.21 errors return. What strikes me as odd is the seeming relationship between clearing the "Temporary ASP.NET Files" folders and the problem going away. I've a practice of clearing the "Temporary ASP.NET Files" folders when installing a new version of our application(s), but not otherwise. Does this relationship ring familiar to anyone? Is there some new-ish IIS7 feature at work here? Text of Error: Server Error in Application "DEFAULT WEB SITE/PAIS" Internet Information Services 7.0 Error Summary HTTP Error 500.21 - Internal Server Error Handler "PageHandlerFactory-Integrated" has a bad module "ManagedPipelineHandler" in its module list Detailed Error Information Module IIS Web Core Notification ExecuteRequestHandler Handler PageHandlerFactory-Integrated Error Code 0x8007000d Requested URL http://localhost:80/PAIS/Admin.aspx Physical Path C:\0_Georgia\GA_IS_100142\PortfolioArchiveImageServer\Admin.aspx Logon Method Anonymous Logon User Anonymous Most likely causes: • ASP.NET is not installed or incompletely installed. • A configuration typographical error occured. • Unfavourable pre-condition evalu
Tags (comma-separated)
Save Edits
Cancel