KnowledgeHub
Questions
Tags
Users
Search
Alex Rivera
|
Logout
Edit Question
Title
Body
For installing postgresql 9.2 I followed this url : http://www.ubuntugeek.com/how-to-install-postgresql-9-2-on-ubuntu-server-using-ppa.html But at the end of installation output is like : Setting up postgresql-common (140~precise) ... locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory Adding user postgres to group ssl-cert Building PostgreSQL dictionaries from installed myspell/hunspell packages... * No PostgreSQL clusters exist; see "man pg_createcluster" Setting up postgresql-9.2 (9.2.4-0ppa1~precise) ... Error: The locale requested by the environment is invalid. Error: could not create default cluster. Please create it manually with pg_createcluster 9.2 main --start or a similar command (see 'man pg_createcluster'). update-alternatives: using /usr/share/postgresql/9.2/man/man1/postmaster.1.gz to provide /usr/share/man/man1/postmaster.1.gz (postmaster.1.gz) in auto mode. * No PostgreSQL clusters exist; see "man pg_createcluster" Processing triggers for libc-bin ... ldconfig deferred processing now taking place And when I tried to start postgresql, it gives following error : sudo /etc/init.d/postgresql start perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LC_MESSAGES = "en_IN.UTF-8", LANG = "en_US.UTF-8" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). * No PostgreSQL clusters exist; see "man pg_createcluster" How can I fix this problem ?
Tags (comma-separated)
Save Edits
Cancel