Alex Rivera | Logout

MySQL: #126 - Incorrect key file for table

Asked 2010-01-06T05:01:44.140
110

I got the following error from a MySQL query.

#126 - Incorrect key file for table

I have not even declared a key for this table, but I do have indices. Does anyone know what could be the problem?

Edit
Report

1 Answer

10

Error #126 usually occurs when you got a corrupt table. The best way to solve this is to perform repair. This article might help:

http://dev.mysql.com/doc/refman/5.0/en/repair-table.html

answered 2010-01-06T05:13:22.033

Your Answer