KnowledgeHub
Questions
Tags
Users
Search
Alex Rivera
|
Logout
Edit Question
Title
Body
Symptoms In IIS 7 and Dot Net 2.0 Integrated app pool: double clicking to view any web.config section results in an error dialog like this: Browsing to the URL displays: "Http 500.19" internal server error.. There is a duplicate... 'system.web.extensions/scripting/scriptResourceHandler' section defined...." Running the app from VS 2008 an "Unable to start debugging on the web server..." dialog is displayed. Infrastructure Web server: IIS 7 running on Windows 7 x64 ASP.Net MVC2 Application pool: Dot Net 2.0 integrated VS 2008 Things Tried Checked to see if the problem was occurring in other IIS app directories on the same machine. Removed and re-added the application in IIS. Reverted to prior versions of the web.config file. Checked out a last working version of the source code. Rebuilt the app, added a new app directory for it and tried to view web.config contents from IIS. Looked for web.config files that might have duplicate sections in: Inetpub root. "C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config" The "Views" subfolder of the ASP.Net MVC app. Checked out source code to another dev machine. Setup IIS 7 app folder. No problem with Web.config. Question If the reason for this error is another web.config file where else should I look? Are there other reasons for these symptoms?
Tags (comma-separated)
Save Edits
Cancel