KnowledgeHub
Questions
Tags
Users
Search
Alex Rivera
|
Logout
Edit Question
Title
Body
In WebSphere 6.1 I have created a datasource to an Oracle 11g instance using the thin JDBC client. In Oracle I have two users, one existing and another newly created. My websphere datasource is OK if I use the component-managed authentication alias of the existing user, but fails with "invalid user/password" message if I use the alias of the new user. The error message is: The test connection operation failed for data source MyDB (Non-XA) on server nodeagent at node MY_node with the following exception: java.sql.SQLException: ORA-01017: invalid username/password; logon denied DSRA0010E: SQL State = 72000, Error Code = 1,017. View JVM logs for further details. There is nothing in the JVM logs. I have grepped all websphere logs and they do not mention my connection at all. I can confirm that the username and password are correct by logging in via SQLPlus or (to prove the JDBC connection is OK) via SQuirreL. I have checked in Oracle that the new user has all the system privs that the existing user has. Any thoughts on what is going on or how I can debug this further?
Tags (comma-separated)
Save Edits
Cancel