Alex Rivera | Logout

How to debug Azure 500 internal server error

Asked 2011-06-12T20:29:27.277
31

My newly deployed site is getting a 500 internal server error. I'm trying to deploy Umbraco to Azure.

I've turned off custom errors but that doesn't help.

Is there anyway to see the error that Azure is throwing?

SOLVED
I was able to edit my configuration and setup RDP into my web role. Once on the box I couldn't go to it via IP because I'm using the umbraco accelerator. There was a binding in IIS to go to 0.mydomain.com. If I used that I could see the page from the server and the error came up.

Edit
Report

1 Answer

12

For 500 errors, one good way is to turn diagnostics on and to look at the logs - both the application event logs and the failed request logs might help. Here's one post about this - http://oakleafblog.blogspot.com/2010/11/adding-trace-event-counter-and-error.html

As Igorek has said, you can also use RDP (remote desktop) to log in and to check the app - here's a good blog post about this - https://blogs.msdn.com/b/jimoneil/archive/2011/04/11/500-and-other-errors-in-azure-deployments.aspx


My guess is that you might be missing one or more Assemblies from the deployed package

answered 2011-06-13T08:45:32.803

Your Answer