Alex Rivera | Logout

HTTP Error 404.17 - Not Found

Asked 2011-08-16T18:58:41.087
49

IN VS 2008 i can run .svc but on production IIS 7 i can't. I get this error. i am using x64 win.

I run

C:\Windows\Microsoft.NET\Framework\v2.5.0.30319>aspnet_regiis.exe -i
Start installing ASP.NET (4.0.30319).
.........................

and

C:\Windows\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -i
The error indicates that IIS is not installed on the machine. Please install IIS
Finished installing ASP.NET (2.0.50727).

but it is the same. I run VS 2008. Application pool :NET framweork is 2.0. And i enable 32 bit application

    Error Summary
HTTP Error 404.17 - Not Found
The requested content appears to be script and will not be served by the static file handler.
Detailed Error Information
Module  StaticFileModule
Notification    ExecuteRequestHandler
Handler StaticFile
Error Code  0x80070032
Requested URL   http://192.168.2.4:80/Service.svc
Physical Path   C:\inetpub\wwwroot\WebServices\Service.svc
Logon Method    Anonymous
Logon User  Anonymous
Most likely causes:

    The request matched a wildcard mime map. The request is mapped to the static file handler. If there were different pre-conditions, the request will map to a different handler.

Things you can try:

    If you want to serve this content as a static file, add an explicit MIME map.

EDIT:

web.config

<?xml version="1.0"?>

<!--
    Note: As an alternative to hand editing this file you can use the 
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in 
    machine.config.comments usually located in 
    \Windows\Microsoft.Net\Framework\v2.x\Config 
-->
<configuration>
    <configSections>
        <section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler,log4net" />
        
Edit
Report

1 Answer

51

I had receievd a similar error:

HTTP Error 404.17 - Not Found
The requested content appears to be script and will not be served by the static file handler.

I tried the same code on several machines. Through some R & D, I finally found that the cause for this can be that WCF mapping are not registered with IIS.

To solve the above error:

  1. Navigate to "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation" at the Visual Studio command prompt
  2. Execute servicemodelreg -i to install the mappings manually
answered 2011-08-25T05:06:10.637

Your Answer