We're switching our MVC3 application from IIS 6 to 7.5. I'm working on setting up my local development environment on Windows 7. The app works fine for the most part, but I just discovered that ONE out of the many different MVC Areas I have doesn't work.

When I try hit an action under this area, I get a 503 Service Unavailable error back. This does not happen anywhere else in my application.

  • There is only one application pool for the whole website.
  • MVC 3
  • .Net 4.0
  • 64 bit
  • Failed request tracing doesn't see these requests.
  • There is nothing relevant in the Windows application or system logs.
  • The area works fine under visual studio 2010 cassini, problem happens when I run it under local iis 7.5 (not express)
  • App pool isn't crashing or otherwise stopped
  • There's nothing in my ELMAH log
  • Everyone full control on entire tree in the filesystem security
  • The url is http://localhost/reports

I'm totally stumped. I can't find any evidence that IIS is even getting the request at all. Is there some other log file beside the ones I listed?

[Update] Is there any way to view the http.sys URL reservations? I have found some talk about SQL Reporting services calling dibs on /Reports url.

Edit
Report