34
Our deployment works fine at 15 replicas but when the HPA scales to 20+ we get CrashLoopBackOff. The pods fail with OOMKilled despite having 512Mi memory limits. I suspect connection pool exhaustion to our PostgreSQL instance but I'm not sure how to confirm. Resource quotas on the namespace have plenty of headroom...