Alex Rivera | Logout

Unable to launch the ASP.NET Development server because port '1900' is in use

Asked 2009-02-01T15:02:34.347
32

I was developing just fine in VS 2008 and testing my ASP.NET web site on my development server when suddenly I was unable to run my web site anymore. As soon as I hit F5, the message appears:

Unable to launch the ASP.NET Development server because port '1900' is in use.

It doesn't matter what port I change to, it's always in use. I have tried:

  • Changing the port number
  • Restarting Visual Studio
  • Rebooting my machine
  • Installing IIS

Clue: My IIS refuses to start. But I didn't have IIS installed when I was happily working earlier, so that is probably not the issue; it might just be highlighting something else.


Update: after rebooting, IIS does start, but the problem here persists.

Edit
Report

2 Answers

5

The problem was solved for me configuring NOD32 firewall to no longer see VS like a browser.

Setup>Antivirus & AntiSpy>Internet protection>HTTP

Just uncheck the vs, and the issue will be resolved.

I hope this finally helps.

answered 2011-07-05T12:27:08.700
4

I had the same problem for a long time. I checked all the ideas written here. Eventually the only thing that worked for me was:

  1. Unload the project by right clicking it.
  2. Opening the .csproj file by right click the unloaded projoect
  3. Reloading the project (without any change)

Sometimes it solves the problem...

However, I also have a workaround:

  1. Open your Visual Studio 2008 Command Prompt (Start-> Microsoft Visual Studio 2008 -> Visual Studio Tools -> Command Prompt).
  2. Type : webdev.webserver.exe /port:[your_port] /path:"[your_path]"
    your_port is the desired port for the server, your_path is the path where VS stores your source file. Note that you need to paste only the directory where your .asmx file is.
  3. This should run the server manually and listen on the specified port.
answered 2009-10-07T16:33:33.880

Your Answer